Jan Wieck JanWieck at Yahoo.com
Tue Sep 25 11:24:35 PDT 2007
On 9/25/2007 1:58 PM, Marko Kreen wrote:
> On 9/25/07, Jan Wieck <JanWieck at yahoo.com> wrote:
>> On 9/25/2007 12:21 PM, Marko Kreen wrote:
>> > On 9/25/07, Jan Wieck <JanWieck at yahoo.com> wrote:
>> >>    bool          txid_lt_snapshot(int8, sn)
>> >>    bool          txid_le_snapshot(int8, sn)
>> >>    bool          txid_ge_snapshot(int8, sn)
>> >>    bool          txid_gt_snapshot(int8, sn)
>> >
>> > Why so many variants?  Isn't one enough?
>>
>> Right again, only _lt_ and _gt_ make sense, because the snapshot itself
>> doesn't have a particular xid associated with it, so there is no
>> definition of an xid being equal to a snapshot.
>>
>> > And I think that should be with clearer name like
>> > txid_is_visible() or txid_is_committed().
>>
>> txid_lt_snapshot() would then be txid_committed_before(int8, sn) and
>> txid_gt_snapshot() respectively txid_committed_after(int8, sn).
> 
> Considering one is NOT other, are both needed?
> 
> I just think it's preferable to avoid duplications and
> keep the API minimal.

The same would apply to comparison operators. > is the same as NOT <= 
... yet we prefer to have both available as it makes code more readable.


Jan

-- 
#======================================================================#
# It's easier to get forgiveness for being wrong than for being right. #
# Let's break this rule - forgive me.                                  #
#================================================== JanWieck at Yahoo.com #


More information about the Slony1-hackers mailing list